Booking Funnels Not rendering

Incident Report for Emil Insurance Suite

Update

The issue affecting some booking funnels has been resolved and service is back to normal. We're continuing to monitor to confirm stability.
Posted Jul 09, 2026 - 12:30 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 09, 2026 - 11:07 CEST

Monitoring

We've identified and fixed the issue affecting booking funnels. Loading and display should now be back to normal. We're currently monitoring.
Posted Jul 09, 2026 - 09:04 CEST

Investigating

Some booking funnels are currently failing to load or displaying incorrectly for affected users. We're aware of the issue and actively investigating.

We are actively investigating the issue.
Posted Jul 09, 2026 - 08:44 CEST
This incident affects: EU Frankfurt (EIS Widgets).