Service Disruption in Zurich Region

Incident Report for Emil Insurance Suite

Resolved

The issue affecting services in the Zurich region has been resolved. All services are now operating normally.

Our team will continue to monitor the systems to ensure continued stability. Thank you for your patience during this incident.
Posted Mar 07, 2026 - 21:43 CET

Monitoring

Services in the Zurich region appear to be restored and are operating normally again. Our team continues to monitor the systems closely to ensure stability and to prevent further disruptions.

We will provide additional updates if any new information becomes available. Thank you for your patience.
Posted Mar 07, 2026 - 21:22 CET

Investigating

We are currently experiencing a service disruption affecting systems hosted in the Zurich region. As a result, some services may be temporarily unavailable.

Our engineering team is actively investigating the issue and working to restore normal operations as quickly as possible. We will provide further updates as more information becomes available.
Posted Mar 07, 2026 - 21:05 CET
This incident affected: EU Zürich (Accounts API, Auth API, Billing API, Claims API, Customers API, Documents API, Insurance API, Payments API, Process Manager API, Public API, Tenants API, EIS Admin, Emily).