Policies cannot be opened on Frontend on Zurich region

Incident Report for Emil Insurance Suite

Resolved

This incident has been resolved. The issue was relating to an internal package which has been resolved.

The newest version of paymentservice is currently on production as expected.
Posted Oct 02, 2025 - 18:32 CEST

Monitoring

We rolled back the previous version of payment service, it is now back to normal.

We have identified the issue and are working on deploying latest updates soon.
Posted Oct 02, 2025 - 17:48 CEST

Update

We are continuing to investigate this issue. Leads are still being created normally and nothing else seems impacted.
Posted Oct 02, 2025 - 17:44 CEST

Investigating

We noticed that the policies cannot be opened during right after our deployment. We are currently investigating what happened.
Posted Oct 02, 2025 - 17:43 CEST
This incident affected: EU Zürich (Payments API, EIS Admin).